Batch Processing

The tools that appear in the Tools menu can only be used to process the file that is currently open in DVMP Pro. But the Batch Processing facility allows you to process several files in one go. Most of the Batch Processing operations are the same as the tools found in the Tools menu.

 

Some batch operations are only supported for specific file types. Below is a summary of the currently available batch operations and supported file types.  Click on the name of the batch operation in the table for a description of each operation.

 

 


DV file types

MPEG-2 Program Stream file types

Other file types

Tools Menu

DV AVI

Raw DV

DV MOV

Sony HDD & DVD

MOD

HDV M2T

AVCHD MTS/M2TS

MOV & MP4

Burn-in Time Stamp

tick

 

tick

tick

tick

tick

tick

tick

Burn-In Metadata

tick

 

tick

tick

tick

tick

tick

tick

Fix Aspect Ratio of MOD/MPEG-2 PS Files

 

 

 

tick

tick

 

 

 

Extract Audio

tick

 

 

tick

tick

tick

tick

tick

Export Metadata

tick

tick

tick

tick

tick

tick

tick

tick

Export Subtitles

tick

tick

tick

tick

tick

tick

tick

tick

Export GPS Track

 

 

 

tick

 

 

tick

tick

Convert DV file to DV AVI Type 1

tick

tick

 

 

 

 

 

 

Convert DV file to DV AVI Type 2

tick

tick

 

 

 

 

 

 

Convert DV File to Raw DV

tick

 

 

 

 

 

 

 

Modify DV Metadata

tick

 

tick

 

 

 

 

 

Split DV AVI File

tick

 

 

 

 

 

 

 

Set "Date created" to Start Date/Time

tick

tick

tick

tick

tick

tick

tick

tick

Set "Date modified" to Start Date/Time

tick

tick

tick

tick

tick

tick

tick

tick

Append Start Date/Time to file name

tick

tick

tick

tick

tick

tick

tick

tick

Fix Premiere Start Timecode in DV AVI

tick

 

 

 

 

 

 

 

 

Note that the "Export GPS Track" operation will only work for files that actually contain GPS data (i.e. the camera has a built-in GPS unit that was activated and storing GPS data while recording).

 

The final 4 operations in this table are only to be found in the Batch Processing module. They are not found in the Tools menu. A description of them follows.

 

Batch Only Operations

 

The following operations are found only in the Batch Processing facility. They do not exist on the Tools menu.

 

Set "Date created" to Start Date/Time

 

The Set "Date created" to Start Date/Time operation sets the "Date created" file property of the input files to the start date and time when they were recorded. The date and time are extracted from the currently selected Metadata Source (with an adjustment if the Adjust Date and Time setting is used).

 

This operation does not have any output files as such, and therefore the only file that is created in the output folder is the log file.

 

The "Date created" file property is displayed in File Explorer or Windows Explorer and in the file property window of many video editing applications, so it provides an easy way of seeing when files were actually recorded, and sorting them by recording date.

 

Please note that the "Date created" file property is also one of the selectable Metadata Sources. So if Filesystem "Date Created" is the currently selected Metadata Source, then this operation will effectively be setting the "Date created" to itself! This would seem pointless, but it does take account of the Adjust Date and Time setting which can therefore be used to apply a change to the input file's "Date created" file property.

 

Set "Date modified" to Start Date/Time

 

The Set "Date modified" to Start Date/Time operation is effectively the same as the Set "Date created" to Start Date/Time operation described above, except that the "Date modified" file property is set.

 

Please note that the "Date modified" file property is also one of the selectable Metadata Sources. So if Filesystem "Date Modified" is the currently selected Metadata Source, then this operation will effectively be setting the "Date modified" to itself! This would seem pointless, but it does take account of the Adjust Date and Time setting which can therefore be used to apply a change to the input file's "Date modified" file property.

 

Append Start Date/Time to file name

 

The Append Start Date/Time to file name operation renames the input files by appending the start date and time of recording to the filename in the format yyyy-mm-dd hh.mm.ss. The date and time are extracted from the currently selected Metadata Source (with an adjustment if the Adjust Date and Time setting is used).

 

For example, the HDV file

 

myfile.m2t

 

would be renamed to

 

myfile 2008-12-19 15.23.58.m2t

 

This operation does not have any output files as such, and therefore the only file that is created in the output folder is the log file.

 

Fix Premiere Start Timecode in DV AVI

 

The Fix Premiere Start Timecode in DV AVI operation adds an Adobe Premiere Start Timecode header to existing DV AVI input files. If the Start Timecode header is already present then it is corrected using the DV metadata timecode of the first frame in the file.

 

This requires some explanation.

 

When a DV camera is recording to tape it stores a timecode in the DV metadata areas of each video frame. When a clip is captured to a DV AVI file, the start timecode for the file will therefore be found in the metadata area of the first frame in the DV AVI file.

 

However, Adobe Premiere reads the start timecode of a DV AVI file from a special Premiere AVI header instead of reading the timecode from the DV metadata of the first video frame. If this Premiere header does not exist (which usually happens if the AVI file was captured in another application) then Premiere will assume a start timecode of 00:00:00:00 for the file regardless of the true start timecode in the DV metadata. In such cases this operation can be used to add the Premiere header so that it contains the correct start timecode (copied from the DV metadata of the first frame in the file). This means that the start timecode in the Premiere header will be in agreement with the timecode in the first frame's metadata.

 

Also, sometimes the Premiere header's start timecode value may have been set incorrectly. If the file already contains a Premiere start timecode header, this operation will correct it by setting it equal to the DV metadata timecode of the first frame.

 

Note that this operation adds/corrects the Premiere header of the input files. This is because it is not necessary for the files to be copied just to add the header - the operation is therefore extremely fast even for large files. There are no output files as such, and therefore the only file that is created in the output folder is the batch processing log file.

 

How to Use the Batch Processing facility

 

pro-batch-beforeClick the File > Batch Processing menu and the Batch Processing window appears. This is independent of the main DVMP Pro window, so you can still play files or change Tools > Options settings while the Batch Processing window is open.

 

You give Batch Processing a list of input files and it processes each file in turn. The output files are all stored in a single output folder, and are given the same file name as the input files but with a suitable suffix that identifies the operation that has been performed.

 

You add files to the input file list by clicking the Add button. This opens a file selection dialog where you can select one or more files (using SHIFT-click or CTRL-click to select multiple files). Click OK and the files are added to the list-box headed Files to be processed. If any files are not recognised as supported file-types a warning message box appears and those files are not added to the list.

 

You can add more files to the list simply by using the Add button again. The extra files are added to the end of the list-box.

 

You can also add files to the list by dragging the files from another program such as File Explorer or Windows Explorer and dropping them onto the list-box. This is often more convenient than using the Add button.

 

When files are added to the list-box they have a check mark against them. This tells the Batch Processor to process that file. If you want a file to not be processed (but you'd prefer to leave it in the list) just un-check the file.

 

You can remove files from the list-box by clicking the file to highlight it and then clicking the Remove button. Multiple files can be removed by SHIFT or CTRL-clicking files to highlight them - for example you can remove all files from the list by clicking the first file, scrolling to the bottom and SHIFT-clicking the last file, then clicking the Remove button. (Alternatively, you can press CTRL-A to select all files then click the Remove button.)

 

Files are processed in the order that they appear in the list box. However you can easily change the order simply by clicking a file in the list box and then dragging and dropping it at the new position. You can also use SHIFT and CTRL-click to drag multiple files.

 

Now choose a folder where the output files will be created. You do this by clicking the Browse button. A Select Folder dialog box appears where you select the output folder.

 

Now select the operation that is to be performed from the Operation drop-down list. You will find some of the operations here that you've seen under DVMP Pro's Tools menu.

 

Note that some batch operations are only supported for specific file types. See the table above for a list of operations and their supported file types.

 

pro-batch-progressingHaving selected the operation, you can now run the Batch Processor by clicking the START button.

 

If the operation you chose has some associated settings then a Confirm Settings dialog box will appear which allows you to check that these are all correct, and change them if necessary. (These are the same settings that you can see in the Tools > Options menu.) When you are satisfied with the settings just click the OK button and the batch processor will start processing the files.

 

If the operation you chose does not have any associated settings (e.g. file conversion) then the batch processor will run immediately when you press the START button.

 

As each file is processed, the two progress bars at the bottom of the window show the progress through the current file and an estimation of the progress through the entire batch run.

 

Also, progress messages will appear in the Output Log pane. These messages are also written to a log file in the output folder.

 

The batch processor will never overwrite existing files. If the output folder already contains a file with the same name as a new file which needs to be created, the new file will have a (n) suffix added to it, where "n" is a number that will guarantee a unique file name.

 

You can abort batch processing by clicking the Abort button. All output files created so far will be left intact, but if a file is currently being written-to then it will be deleted - it's probably of no use as it will be incomplete anyway. If you abort frequently then keep an eye on the contents of the output folder as it can fill up quickly with files from previous aborted runs.

 

pro-batch-finishedWhen the Batch Processing run is complete, a Finished message appears in the Output Log pane, stating the number of files that were successfully processed and the number that failed. If there are 1 or more failures, you can scroll back through the messages in the pane (or examine the log file in the output folder) to see what error messages were output as each file was processed. It is especially important to do this if the Finished message says that there are 1 or more failures.

 

Note that one reason for failure may simply be that the selected Operation is not supported for one of more of the file types in the Files to be processed list - the error message in the Output Log pane will tell you this. If this happens, check the table of supported batch operations and file types at the start of this chapter.

 

When you are finished batch processing, you can close the window by clicking the Close button.

 

Note that you can not Exit from DVMP Pro while the Batch Processing window is open.

 

See Also:

Tools Menu